[Aphrodite] Yellow Card Mod

Specific instructions on how to apply certain mods to certain styles.

Moderator: Moderators

[Aphrodite] Yellow Card Mod

Postby UseLess on Wed Mar 30, 2005 12:04 am

Greetings,

This update will make the mod fit in with the style better as shown here:

Screenshot: Image

or with text buttons: Image

Updated images and code change instructions can be found here:

http://custombuiltsoftware.co.uk/downlo ... rodite.zip
Last edited by UseLess on Thu May 19, 2005 8:26 pm, edited 1 time in total.
Movie Quote:
It's not the years honey, it's the mileage...

I do not provide any install services for phpBB, Mods or Styles.
Please do not pm me for support/scripting help - you won't get any reply. If you have a question then make a post in the appropriate forum.
User avatar
UseLess
Registered User
Registered User
 
Posts: 6220
Joined: Mon Sep 27, 2004 2:14 am
Location: North East, UK

Postby broxiger on Thu Mar 31, 2005 12:23 pm

Wheres the original files?
broxiger
Registered User
Registered User
 
Posts: 38
Joined: Wed Jan 12, 2005 7:01 pm
Location: UK

Postby kvfb97 on Thu Mar 31, 2005 1:02 pm

You can get them here...

http://mods.db9.dk

But the site seems to be down with me at the minute...
Tip: Don't argue with idiots, they'll drag you down to their level and beat you with experience.
User avatar
kvfb97
Registered User
Registered User
 
Posts: 1774
Joined: Mon Aug 02, 2004 8:18 am
Location: Northern Ireland, UK

Postby UseLess on Thu Mar 31, 2005 6:39 pm

Movie Quote:
It's not the years honey, it's the mileage...

I do not provide any install services for phpBB, Mods or Styles.
Please do not pm me for support/scripting help - you won't get any reply. If you have a question then make a post in the appropriate forum.
User avatar
UseLess
Registered User
Registered User
 
Posts: 6220
Joined: Mon Sep 27, 2004 2:14 am
Location: North East, UK

Postby Bicet on Fri Apr 15, 2005 6:49 pm

Sorry for the pm, I did'nt search acurately ;)

Now I'm happier ;)
User avatar
Bicet
Coder
Coder
 
Posts: 247
Joined: Mon Nov 15, 2004 7:50 pm

Postby broxiger on Mon Apr 25, 2005 10:42 pm

[quote user="kvfb97" post="26334"]You can get them here...

http://mods.db9.dk

But the site seems to be down with me at the minute...[/quote]

Thanks mate...
broxiger
Registered User
Registered User
 
Posts: 38
Joined: Wed Jan 12, 2005 7:01 pm
Location: UK

Postby MrBass on Tue May 03, 2005 9:47 am

I'm having a bit of grief with the Yellow Card mod.

I've made all the necessary amendments, including the one posted by UseLess in this thread but for some reason I get different problems depending on which style I use.

If I use the subSilver style, everything bar the image near the user details works fine. For yellow carded users, near their avatar I get a symbol as if a picture cannot be found, but it displays the right number of warnings. I thought this might be because the image name is slightly different for UseLess style update - UseLess' file name is icon_ycards.gif, whearas the original was icon_ycard.gif. I tried amending but still no joy.

More importantly though is the problem with the Aphrodite style. The cards up near the Quote IP buttons, appear but they're all blank (not coloured as per UseLess screen dump). Also they're not inline with the other buttons, they're a fraction below for some reason. If I hover over the buttons I get the correct Alt text but if I click them, after getting the prompt of what I've selected, I click OK and nothing happens, I just return to the post. The card count doesn't increase or anything so it's as if it's missing a block of code somewhere. Odd thing is, the buttons work fine in subSilver . :?

Any suggestions gratefully received!
User avatar
MrBass
Moderator
Moderator
 
Posts: 711
Joined: Thu Feb 17, 2005 2:06 pm
Location: Pete's Place

Postby UseLess on Tue May 03, 2005 11:57 am

Greetings,

The images 'icon_ycards.gif' and 'icon_rcards.gif' are used by the modded styles I have done to show the number of warnings a user has under their details in a post. As the original images have been altered to suit the style and therefore would look silly if also used to display the number of warnings etc.

If your using Aphrodite then have you also made the changes to the CSS file?

And have you copied the images in the packege to the 'templates/ca_aphrodite/images' directory?

Also have you replaced the code as detailed in the install.txt file with that provided in the 'card.php' file?

Also spotted a mistake, the bit in the cfg file should be as follows;

Code: Select all
#
#-----[ OPEN ]------------------------------------------
#

templates/ca_aphrodite/ca_aphrodite.cfg

#
#-----[ FIND ]------------------------------------------
#

// Start add - Yellow card admin MOD
$images['icon_g_card'] = "$current_template_images/icon_gcard.gif";
$images['icon_y_card'] = "$current_template_images/icon_ycard.gif";
$images['icon_r_card'] = "$current_template_images/icon_rcard.gif";
$images['icon_b_card'] = "$current_template_images/icon_bcard.gif";
$images['icon_bhot_card'] = "$current_template_images/icon_bhotcard.gif";

#
#-----[ REPLACE WITH ]------------------------------------------
#

// Start add - Yellow card admin MOD
$images['icon_g_card'] = "$current_template_images/icon_card.gif";
$images['icon_y_card'] = "$current_template_images/icon_card.gif";
$images['icon_r_card'] = "$current_template_images/icon_card.gif";
$images['icon_y_cards'] = "$current_template_images/icon_ycards.gif";
$images['icon_r_cards'] = "$current_template_images/icon_rcards.gif";
$images['icon_b_card'] = "$current_template_images/icon_card.gif";
$images['icon_bhot_card'] = "$current_template_images/icon_card.gif";


In the install.txt file both the find and the replace with were the same code as shown in the replace with.
Movie Quote:
It's not the years honey, it's the mileage...

I do not provide any install services for phpBB, Mods or Styles.
Please do not pm me for support/scripting help - you won't get any reply. If you have a question then make a post in the appropriate forum.
User avatar
UseLess
Registered User
Registered User
 
Posts: 6220
Joined: Mon Sep 27, 2004 2:14 am
Location: North East, UK

Postby MrBass on Tue May 03, 2005 12:46 pm

Hi UseLess,

Everything you've suggested was done during the initial install. The four images all appear top right in users posts but the center of them isn't coloured and they appear slightly lower than the other buttons. I double checked the CSS file as I thought that's where the colouring took place and it all seems okay.

Code: Select all
<..snipped to save space>

/* Card System MOD - Changes for CA Styles */
.img-ban a img { background-color: #990000; }
.img-ban a:hover img { background-color: #FF0000; }
.img-ban a:active img { background-color: #990000; }

.img-warn a img { background-color: #FF9900; }
.img-warn a:hover img { background-color: #FFFF00; }
.img-warn a:active img { background-color: #FF9900; }

.img-clear a img { background-color: #FFCC33; }
.img-clear a:hover img { background-color: #FF7E00; }
.img-clear a:active img { background-color: #FFCC33; }

.img-report a img { background-color: #000099; }
.img-report a:hover img { background-color: #0000FF; }
.img-report a:active img { background-color: #000099; }

.img-green a img { background-color: #009900; }
.img-green a:hover img { background-color: #00FF00; }
.img-green a:active img { background-color: #009900; }


Also, as I said earlier, the alt text appears fine for each button, as does the initial warning prompt but that's as far as it goes.

Very bizarre. :(
Last edited by MrBass on Wed May 04, 2005 10:30 am, edited 1 time in total.
User avatar
MrBass
Moderator
Moderator
 
Posts: 711
Joined: Thu Feb 17, 2005 2:06 pm
Location: Pete's Place

Postby MrBass on Tue May 03, 2005 12:53 pm

Never mind, it was me being a muppet!

When it was checking which template I was using, I didn't realise that the values put into the array were case sensitive and put ca_Aphrodite. Derr!!!

Cheers for your help anyway.

...off to dish out some yellow cards. :)
User avatar
MrBass
Moderator
Moderator
 
Posts: 711
Joined: Thu Feb 17, 2005 2:06 pm
Location: Pete's Place

Postby UseLess on Tue May 03, 2005 5:35 pm

Greetings,

Well you beat me to it as that was going to be my next suggestion.

But glad you got it working...
Movie Quote:
It's not the years honey, it's the mileage...

I do not provide any install services for phpBB, Mods or Styles.
Please do not pm me for support/scripting help - you won't get any reply. If you have a question then make a post in the appropriate forum.
User avatar
UseLess
Registered User
Registered User
 
Posts: 6220
Joined: Mon Sep 27, 2004 2:14 am
Location: North East, UK

Postby UseLess on Fri Nov 04, 2005 1:45 pm

Greetings,

Updated to now include text buttons, see first post for example and download link.

Note: When installing this you now have a choice to make so read the install.txt file carefully... ;)
Movie Quote:
It's not the years honey, it's the mileage...

I do not provide any install services for phpBB, Mods or Styles.
Please do not pm me for support/scripting help - you won't get any reply. If you have a question then make a post in the appropriate forum.
User avatar
UseLess
Registered User
Registered User
 
Posts: 6220
Joined: Mon Sep 27, 2004 2:14 am
Location: North East, UK

Postby znabty on Thu Dec 22, 2005 10:58 pm

[quote user="MrBass" post="31445"]Never mind, it was me being a muppet!

When it was checking which template I was using, I didn't realise that the values put into the array were case sensitive and put ca_Aphrodite. Derr!!!

Cheers for your help anyway.

...off to dish out some yellow cards. :)[/quote]

could you please tell me how you fixed it because i have the same problem.
znabty
Registered User
Registered User
 
Posts: 13
Joined: Mon Dec 19, 2005 12:38 pm

Postby znabty on Thu Dec 22, 2005 11:21 pm

anyone!!!?
znabty
Registered User
Registered User
 
Posts: 13
Joined: Mon Dec 19, 2005 12:38 pm

Postby kvfb97 on Fri Dec 23, 2005 1:13 am

[quote user="UseLess" post="55685"]Greetings,

Updated to now include text buttons, see first post for example and download link.

Note: When installing this you now have a choice to make so read the install.txt file carefully... ;)[/quote]

I installed it but seem to have a html error were the buttons are.

http://www.kvfb97.co.uk/phpbb/viewtopic.php?p=2#2
Tip: Don't argue with idiots, they'll drag you down to their level and beat you with experience.
User avatar
kvfb97
Registered User
Registered User
 
Posts: 1774
Joined: Mon Aug 02, 2004 8:18 am
Location: Northern Ireland, UK

Next

Return to How to mod some styles

Who is online

Users browsing this forum: No registered users and 1 guest

cron