[Aphrodite] Yellow Card Mod

Specific instructions on how to apply certain mods to certain styles.

Moderator: Moderators

Postby Stryker on Wed Mar 29, 2006 4:58 pm

User avatar
Stryker
Registered User
Registered User
 
Posts: 1318
Joined: Mon Aug 29, 2005 7:54 am
Location: ------------

Postby UseLess on Wed Mar 29, 2006 11:08 pm

Greetings,

Link updated.

Image is: templates/ca_aphrodite/images/icon_card.gif colours are handled by CSS classes.
Movie Quote:
It's not the years honey, it's the mileage...

I do not provide any install services for phpBB, Mods or Styles.
Please do not pm me for support/scripting help - you won't get any reply. If you have a question then make a post in the appropriate forum.
User avatar
UseLess
Registered User
Registered User
 
Posts: 6220
Joined: Mon Sep 27, 2004 2:14 am
Location: North East, UK

Postby patch on Tue Aug 08, 2006 2:22 pm

mhh, something ist wrong in my yellow card mod

Image

same colors?!
what is the error

here my css (last part)

Code: Select all
}
.popuppm-new a:hover {
   color: #666;
   text-decoration: underline;
}

/* Yellow Card Mod - Changes for CA Styles */
.img-ban a img { background-color: #990000; }
.img-ban a:hover img { background-color: #FF0000; }
.img-ban a:active img { background-color: #990000; }

.img-warn a img { background-color: #FF9900; }
.img-warn a:hover img { background-color: #FFFF00; }
.img-warn a:active img { background-color: #FF9900; }

.img-clear a img { background-color: #FFCC33; }
.img-clear a:hover img { background-color: #FF7E00; }
.img-clear a:active img { background-color: #FFCC33; }

.img-report a img { background-color: #000099; }
.img-report a:hover img { background-color: #0000FF; }
.img-report a:active img { background-color: #000099; }

.img-green a img { background-color: #009900; }
.img-green a:hover img { background-color: #00FF00; }
.img-green a:active img { background-color: #009900; }
patch
Registered User
Registered User
 
Posts: 5
Joined: Tue Aug 08, 2006 2:20 pm

Postby UseLess on Tue Aug 08, 2006 6:52 pm

Greetings,

Check 'viewtopic.php' and make sure the styles name is in the array here;
Code: Select all
   // Start Yellow Card Changes for phpBB Styles
   $style_used = explode('/', $template->files['body']);
   $allowed_styles = array(
      'Aeolus',
      'Artemis',
      'aphrodite_mc',
      'MorpheusX'
   );
Movie Quote:
It's not the years honey, it's the mileage...

I do not provide any install services for phpBB, Mods or Styles.
Please do not pm me for support/scripting help - you won't get any reply. If you have a question then make a post in the appropriate forum.
User avatar
UseLess
Registered User
Registered User
 
Posts: 6220
Joined: Mon Sep 27, 2004 2:14 am
Location: North East, UK

Postby Realsas on Wed Aug 16, 2006 3:22 pm

where is card.php I can't find it.
User avatar
Realsas
Registered User
Registered User
 
Posts: 28
Joined: Sat Nov 26, 2005 2:38 pm

Postby brandsrus on Wed Aug 16, 2006 3:27 pm

If you installed Yellow Card mod than comes card.php in the root of your forum
brandsrus
Registered User
Registered User
 
Posts: 115
Joined: Fri Jan 06, 2006 6:08 am
Location: Leeuwarden, The Netherlands

Postby senyafin on Wed Oct 25, 2006 4:14 pm

A code snipped from the language File

Code: Select all
$lang['Send_message'] = 'Click %sHere%s to write a message to the moderators or <br />';
$lang['Send_PM_user'] = 'Click %sHere%s to write a PM to the user or';
$lang['Link_to_post'] = 'Click %sHere%s to go to the reported post  <br/>--------------------------------<br/><br/>';


According the reportmade by a user in the Report forum (selected via ACP) a new topic with the related report has been added.
In the body behind the word Here the URL is wrong, reason is a ' =>Here

Also the html code doesnt work [<br/>--------------------------------<br/><br/>]

Could someone explain me how i could fixed that?
Tia
senyafin
Registered User
Registered User
 
Posts: 137
Joined: Sun Sep 24, 2006 5:44 pm

Postby UseLess on Wed Oct 25, 2006 4:56 pm

Greetings,

You using the XS BBCode Parser?

If so then there is a little trickery you have to do in order to get the reported post to show correctly with the link to the actual reported post.

Code: Select all
#
#-----[ OPEN ]-------------------------------------------------------
#

viewtopic.php

#
#-----[ FIND ]-------------------------------------------------------
#

   if($message_compiled === false)
   {

#
#-----[ BEFORE, ADD ]------------------------------------------------
#

   if( $forum_id == $board_config['report_forum'] )
   {
      $xs_bbcode->allow_html = true;
      $message_compiled = false;
   }

#
#-----[ FIND ]-------------------------------------------------------
#

      $xs_bbcode->allow_smilies = $board_config['allow_smilies'] && $postrow[$i]['user_allowsmile'] ? true : false;
      $GLOBALS['code_post_id'] = $postrow[$i]['post_id'];
      $message = $xs_bbcode->parse($message, $bbcode_uid);
      $GLOBALS['code_post_id'] = 0;
      // update database
      $sql = "UPDATE " . POSTS_TEXT_TABLE . " SET post_text_compiled='" . addslashes($message) . "' WHERE post_id='" . $postrow[$i]['post_id'] . "'";
      if( !($db->sql_query($sql)) )
      {
         message_die(GENERAL_ERROR, 'Unable to update compiled text for this post: ' . $postrow[$i]['post_id'], '', __LINE__, __FILE__, $sql);
      }

#
#-----[ AFTER, ADD ]-------------------------------------------------
#

      if( $xs_bbcode->allow_html )
      {
         $xs_bbcode->allow_html = false;
      }

#
#-----[ SAVE/CLOSE ALL FILES ]---------------------------------------
#
# EoM
Movie Quote:
It's not the years honey, it's the mileage...

I do not provide any install services for phpBB, Mods or Styles.
Please do not pm me for support/scripting help - you won't get any reply. If you have a question then make a post in the appropriate forum.
User avatar
UseLess
Registered User
Registered User
 
Posts: 6220
Joined: Mon Sep 27, 2004 2:14 am
Location: North East, UK

Postby senyafin on Wed Oct 25, 2006 5:29 pm

Many thx for the fast response!
UseLess, yes i'm using the XS BBCode Parser.

I've made the recommended changes but the result is still the same.
senyafin
Registered User
Registered User
 
Posts: 137
Joined: Sun Sep 24, 2006 5:44 pm

Postby UseLess on Wed Oct 25, 2006 5:57 pm

Greetings,

Well this is what I see without the changes mentioned above...

Image

and this with the changes...

Image

Therefore if your seeing something different then you would need to check other files... as that is the only problem with using the Yellow Card Mod and the XS BBCode Parser.
Movie Quote:
It's not the years honey, it's the mileage...

I do not provide any install services for phpBB, Mods or Styles.
Please do not pm me for support/scripting help - you won't get any reply. If you have a question then make a post in the appropriate forum.
User avatar
UseLess
Registered User
Registered User
 
Posts: 6220
Joined: Mon Sep 27, 2004 2:14 am
Location: North East, UK

Postby senyafin on Wed Oct 25, 2006 6:04 pm

I'm using the newest build of the XS bbcode Parser.
Here is the body of the message which is added to the Report Forum.

Image

If it works on your board it must be an error on my side.
senyafin
Registered User
Registered User
 
Posts: 137
Joined: Sun Sep 24, 2006 5:44 pm

Postby UseLess on Wed Oct 25, 2006 6:12 pm

Greetings,

Change the lang line to this;

Code: Select all
$lang['Link_to_post'] = "Click %sHere%s to go to the reported post \n--------------------------------\n\n";
Movie Quote:
It's not the years honey, it's the mileage...

I do not provide any install services for phpBB, Mods or Styles.
Please do not pm me for support/scripting help - you won't get any reply. If you have a question then make a post in the appropriate forum.
User avatar
UseLess
Registered User
Registered User
 
Posts: 6220
Joined: Mon Sep 27, 2004 2:14 am
Location: North East, UK

Postby senyafin on Wed Oct 25, 2006 7:03 pm

the format is ok now, looks like the picture you've posted above.
UseLess - did you have checked the url behind the here
There is still the same error (the needless ')-http://www.phpbbstyles.com/'viewtopic.php?t=4459
senyafin
Registered User
Registered User
 
Posts: 137
Joined: Sun Sep 24, 2006 5:44 pm

Postby UseLess on Wed Oct 25, 2006 7:57 pm

Greetings,

The problem is in 'posting.php' in the area after this;
Code: Select all
   //
   // User default entry point
   //

and before this;
Code: Select all
   }
   else
   {
      $subject = '';
      $lock_subject='';
   }

   if ( $mode == 'newtopic' )

I'm sure you'll be able to figure it out... ;)
Movie Quote:
It's not the years honey, it's the mileage...

I do not provide any install services for phpBB, Mods or Styles.
Please do not pm me for support/scripting help - you won't get any reply. If you have a question then make a post in the appropriate forum.
User avatar
UseLess
Registered User
Registered User
 
Posts: 6220
Joined: Mon Sep 27, 2004 2:14 am
Location: North East, UK

Postby senyafin on Wed Oct 25, 2006 10:01 pm

Hello UseLess,
that's the original code from the yellow_card_1.4.12em.txt

I'll be honest, i've no idea :oops:

Code: Select all
#
#-----[ FIND ]------------------------------------------------
#
// User default entry point
//

#
#-----[ AFTER, ADD ]------------------------------------------
#
$postreport=(isset($HTTP_GET_VARS['postreport']))? intval( $HTTP_GET_VARS['postreport']) : 0;
if ($postreport)
{
   $sql = 'SELECT topic_id FROM '.POSTS_TABLE.' WHERE post_id="'.$postreport.'"';
   if( !($result = $db->sql_query($sql) ))
      message_die(GENERAL_ERROR, "Couldn't get post subject information");
   $post_details = $db->sql_fetchrow($result);
   $post_topic_id=$post_details['topic_id'];
   $sql = 'SELECT pt.post_subject FROM '.POSTS_TEXT_TABLE.' pt, '.POSTS_TABLE.' p WHERE p.topic_id="'.$post_topic_id.'" AND pt.post_id=p.post_id ORDER BY p.post_time ASC LIMIT 1';
   if( !($result = $db->sql_query($sql) ))
      message_die(GENERAL_ERROR, "Couldn't get topic subject information".$sql);
   $post_details = $db->sql_fetchrow($result);
   $subject='('.$postreport.')'.$post_details['post_subject'];
   $lock_subject=$postreport;
} else
{
   $subject = '';
   $lock_subject='';
}
senyafin
Registered User
Registered User
 
Posts: 137
Joined: Sun Sep 24, 2006 5:44 pm

PreviousNext

Return to How to mod some styles

Who is online

Users browsing this forum: No registered users and 1 guest

cron