[Aphrodite] Yellow Card Mod

Specific instructions on how to apply certain mods to certain styles.

Moderator: Moderators

Postby Case on Sat Jan 28, 2006 12:25 pm

Code: Select all
code removed
Last edited by Case on Sun Jan 29, 2006 11:13 am, edited 1 time in total.
[size="9"]The Dope Spot - Urban Music Forum[/size]
User avatar
Case
Registered User
Registered User
 
Posts: 751
Joined: Thu Apr 28, 2005 3:27 pm
Location: North West UK

Postby UseLess on Sat Jan 28, 2006 2:00 pm

Greetings,

Well that looks fine in which case it's probably a problem with the auth array and possibly the auth table you may need to add the missing 'AUTH_' bits to the arrays for the extra user levels you've added and then go through every forum checking the permissions, it's easier if you use the permissions list so all forum permissions are displayed on a single page you can then set them all in one go. However this will possibly mean adding a mod to do it, unless you already have the mod installed and then any mods you've added to 'admin/admin_forumauth.php' will also need adding to 'admin/admin_forumauth_list.php' (or whatever the file is called for the list mod you install).
Movie Quote:
It's not the years honey, it's the mileage...

I do not provide any install services for phpBB, Mods or Styles.
Please do not pm me for support/scripting help - you won't get any reply. If you have a question then make a post in the appropriate forum.
User avatar
UseLess
Registered User
Registered User
 
Posts: 6220
Joined: Mon Sep 27, 2004 2:14 am
Location: North East, UK

Postby Case on Sat Jan 28, 2006 2:36 pm

I'm guessing there's no plan B that works for people who don't understand auth array's and adding missing AUTH_ bits?



Seems strange that it actually works fine. Guests or normal users can't actually ban/warn anyone but they can see the buttons.

I've tried setting the permissions to ADMIN but as a guest I can still see the buttons.
[size="9"]The Dope Spot - Urban Music Forum[/size]
User avatar
Case
Registered User
Registered User
 
Posts: 751
Joined: Thu Apr 28, 2005 3:27 pm
Location: North West UK

Postby Case on Sun Jan 29, 2006 5:52 pm

I just noticed that when changing a users level to Administrator I get this error:

Couldn't update auth access

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'group_id = 17' at line 3

UPDATE phpbb_auth_access SET auth_view = 0, auth_read = 0, auth_post = 0, auth_reply = 0, auth_edit = 0, auth_delete = 0, auth_sticky = 0, auth_announce = 0 , auth_ban = 0, auth_greencard = 0, auth_bluecard = 0WHERE group_id = 17

Line : 204
File : admin_ug_auth.php


Could this have something to do with it?


Code: Select all
//
         // Delete any entries in auth_access, they are not required if user is becoming an
         // admin
         //
         $sql = "UPDATE " . AUTH_ACCESS_TABLE . "
            SET auth_view = 0, auth_read = 0, auth_post = 0, auth_reply = 0, auth_edit = 0, auth_delete = 0, auth_sticky = 0, auth_announce = 0, auth_ban = 0, auth_greencard = 0, auth_bluecard = 0WHERE group_id = $group_id";
         if ( !($result = $db->sql_query($sql)) )
         {
            message_die(GENERAL_ERROR, "Couldn't update auth access", "", __LINE__, __FILE__, $sql);
         }
      }
[size="9"]The Dope Spot - Urban Music Forum[/size]
User avatar
Case
Registered User
Registered User
 
Posts: 751
Joined: Thu Apr 28, 2005 3:27 pm
Location: North West UK

Postby Reiji Kurosaky on Sun Jan 29, 2006 6:21 pm

Code: Select all
Couldn't update auth access

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'group_id = 17' at line 3

UPDATE phpbb_auth_access SET auth_view = 0, auth_read = 0, auth_post = 0, auth_reply = 0, auth_edit = 0, auth_delete = 0, auth_sticky = 0, auth_announce = 0 , auth_ban = 0, auth_greencard = 0, auth_bluecard = [highlight]0WHERE[/highlight] group_id = 17

Line : 204
File : admin_ug_auth.php


This is your error.
My sites:
Villavizar.com

My Styles:
[Venus]
User avatar
Reiji Kurosaky
Registered User
Registered User
 
Posts: 858
Joined: Sat Dec 03, 2005 4:05 pm

Postby Case on Sun Jan 29, 2006 6:28 pm

Ah right.

I've corrected that error now but it hasn't made any difference to my original problem with the Yellow card mod.

Thank you anyway.
[size="9"]The Dope Spot - Urban Music Forum[/size]
User avatar
Case
Registered User
Registered User
 
Posts: 751
Joined: Thu Apr 28, 2005 3:27 pm
Location: North West UK

Postby Case on Wed Feb 01, 2006 11:07 am

Useless, any chance you could expand a bit on what I need to do to correct this error? Or have you pretty much posted everything I need to know?

No rush, just whenever you have the chance.

Thanks.
[size="9"]The Dope Spot - Urban Music Forum[/size]
User avatar
Case
Registered User
Registered User
 
Posts: 751
Joined: Thu Apr 28, 2005 3:27 pm
Location: North West UK

Postby Tasadduqkhan on Thu Feb 02, 2006 12:31 pm

I am trying to install this mod but the tpls for subsilver are making me feel bad. I want to instal it for aphrodite but dont know what to edit.
Where should I start?
Tasadduqkhan
Registered User
Registered User
 
Posts: 59
Joined: Thu Jan 05, 2006 9:12 am

Postby Case on Thu Feb 02, 2006 12:51 pm

Download this file Useless posted in his first post and follow the instructions. ;)

http://custombuiltsoftware.co.uk/downlo ... rodite.zip
[size="9"]The Dope Spot - Urban Music Forum[/size]
User avatar
Case
Registered User
Registered User
 
Posts: 751
Joined: Thu Apr 28, 2005 3:27 pm
Location: North West UK

Postby Tasadduqkhan on Thu Feb 02, 2006 1:00 pm

This is just the update to the previous yellow card hack.
I want to know how to edit the tpls of template (aphrodite)
Hoping you get it.
Thanks
Tasadduqkhan
Registered User
Registered User
 
Posts: 59
Joined: Thu Jan 05, 2006 9:12 am

Postby Tasadduqkhan on Thu Feb 02, 2006 1:24 pm

I tried to install Yellow Card Mod using Easy mod every thing went fine but yellow card mod isn't showing up. Anyways I dont want to do it using Easy mod. So I need guidance to install it on ca_aphrodite.
Anyone ?

THanks
Tasadduqkhan
Registered User
Registered User
 
Posts: 59
Joined: Thu Jan 05, 2006 9:12 am

Postby Tasadduqkhan on Thu Feb 02, 2006 2:03 pm

SOrry for posting so much.


http://img404.imageshack.us/img404/9472/navmenu0xw.jpg

The above image is the thing I got in my ACP but this isn't working.

What went wrong.

THanks
Tasadduqkhan
Registered User
Registered User
 
Posts: 59
Joined: Thu Jan 05, 2006 9:12 am

Postby Tasadduqkhan on Fri Feb 03, 2006 10:12 am

Anyhelp?
Tasadduqkhan
Registered User
Registered User
 
Posts: 59
Joined: Thu Jan 05, 2006 9:12 am

Postby UseLess on Mon Feb 20, 2006 1:54 pm

Greetings,

Tasaddugkhan: You need to install the mod as detailed in the install file for the mod, the best thing do to is install the mod into subSilver and then see if it's all working as it should. If or when it is you can then alter the template files for the style your using and if it then does not work you know it's a template problem and not a php problem. You can then make the changes as detailed in this post to get it working with Aphrodite.

Case: do this;

Code: Select all
#
#-----[ OPEN ]-------------------------------------------------------
#

viewtopic.php

#
#-----[ FIND ]-------------------------------------------------------
#

$sql = "SELECT t.topic_id, t.topic_title, t.topic_status, t.topic_replies, t.topic_time, t.topic_type, t.topic_vote, t.topic_last_post_id, f.forum_name, f.forum_status, f.forum_id, f.auth_view, f.auth_read, f.auth_post, f.auth_reply, f.auth_edit, f.auth_delete, f.auth_sticky, f.auth_announce, f.auth_pollcreate, f.auth_vote, f.auth_attachments" . $count_sql . "

#
#-----[ REPLACE WITH ]-----------------------------------------------
#

$sql = "SELECT t.topic_id, t.topic_title, t.topic_status, t.topic_replies, t.topic_time, t.topic_type, t.topic_vote, t.topic_last_post_id, f.forum_name, f.forum_status, f.forum_id, f.auth_view, f.auth_read, f.auth_post, f.auth_reply, f.auth_edit, f.auth_delete, f.auth_sticky, f.auth_announce, f.auth_pollcreate, f.auth_vote, f.auth_attachments, f.auth_ban, f.auth_greencard, f.auth_bluecard" . $count_sql . "

#
#-----[ SAVE/CLOSE ALL FILES ]---------------------------------------
#
# EoM


as you can see you missed something... ;) and sorry for the delay but been a little busy.
Movie Quote:
It's not the years honey, it's the mileage...

I do not provide any install services for phpBB, Mods or Styles.
Please do not pm me for support/scripting help - you won't get any reply. If you have a question then make a post in the appropriate forum.
User avatar
UseLess
Registered User
Registered User
 
Posts: 6220
Joined: Mon Sep 27, 2004 2:14 am
Location: North East, UK

Postby Case on Mon Feb 20, 2006 2:01 pm

Aghh! That's what it was?

I've give this a try later then.

Great stuff Useless, thanks again.
[size="9"]The Dope Spot - Urban Music Forum[/size]
User avatar
Case
Registered User
Registered User
 
Posts: 751
Joined: Thu Apr 28, 2005 3:27 pm
Location: North West UK

PreviousNext

Return to How to mod some styles

Who is online

Users browsing this forum: No registered users and 1 guest

cron